Formstack Forms: Confirmation Email Delivery Issues

Incident Report for Intellistack

Resolved

This issue has been resolved. Confirmation emails to Microsoft-hosted email addresses are now being delivered as expected.
Posted Aug 17, 2026 - 09:04 EDT

Monitoring

The issue affecting confirmation email delivery to Microsoft-hosted email addresses has been resolved. Confirmation emails should now be delivered as expected moving forward.

We will continue to monitor for any additional issues.
Posted Aug 17, 2026 - 08:21 EDT

Investigating

We are currently investigating an issue where some customers may receive unexpected account deactivation notifications related to bounced confirmation emails.

Our team is actively working to identify the cause. We will provide additional updates as more information becomes available.
Posted Aug 17, 2026 - 07:57 EDT
This incident affected: Formstack Forms (Email System (SendGrid)).